summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/automation/light_buttons.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/ham/automation/light_buttons.nix')
-rw-r--r--makefu/2configs/ham/automation/light_buttons.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/makefu/2configs/ham/automation/light_buttons.nix b/makefu/2configs/ham/automation/light_buttons.nix
new file mode 100644
index 00000000..7b43027f
--- /dev/null
+++ b/makefu/2configs/ham/automation/light_buttons.nix
@@ -0,0 +1,33 @@
+let
+ toggle = light: btn:
+ {
+ alias = "Toggle Light ${light} via ${btn}";
+ trigger = {
+ platform = "state";
+ entity_id = "sensor.${btn}_click";
+ to = "single";
+ };
+ action = {
+ service = "light.toggle";
+ entity = light;
+ };
+ };
+ turn_off_all = btn:
+ {
+ alias = "Turn of all lights via ${btn} double click";
+ trigger = {
+ platform = "state";
+ entity_id = "sensor.${btn}_click";
+ to = "double";
+ };
+ action = {
+ service = "light.turn_off";
+ entity = "light.alle_lichter";
+ };
+ };
+in {
+ services.home-assistant.config.automation = [
+ (toggle "light.wohnzimmer_lichter" "btn3")
+ (turn_off_all "btn3")
+ ];
+}