summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/editor/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/editor/vim.nix')
-rw-r--r--makefu/2configs/editor/vim.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/makefu/2configs/editor/vim.nix b/makefu/2configs/editor/vim.nix
index 5751bf48..07f80719 100644
--- a/makefu/2configs/editor/vim.nix
+++ b/makefu/2configs/editor/vim.nix
@@ -6,16 +6,15 @@
((pkgs.vim_configurable.override { python = pkgs.python3; }).customize {
name = "vim";
vimrcConfig.customRC = builtins.readFile ./vimrc;
- vimrcConfig.vam.knownPlugins = pkgs.vimPlugins;
- vimrcConfig.vam.pluginDictionaries = [
- { names = [ "undotree"
+ vimrcConfig.packages.myVimPackage = with pkgs.vimPlugins; { start = [
+ "undotree"
"YouCompleteMe"
#"UltiSnips"
- "vim-better-whitespace" ]; }
# vim-nix handles indentation better but does not perform sanity
- { names = [ "vim-addon-nix" ]; ft_regex = "^nix\$"; }
+ "vim-addon-nix"
+ "vim-better-whitespace"
];
-
+ };
})
];
}