summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/rss/rss.euer.krebsco.de.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/deployment/rss/rss.euer.krebsco.de.nix')
-rw-r--r--makefu/2configs/deployment/rss/rss.euer.krebsco.de.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/makefu/2configs/deployment/rss/rss.euer.krebsco.de.nix b/makefu/2configs/deployment/rss/rss.euer.krebsco.de.nix
new file mode 100644
index 00000000..7e077d7e
--- /dev/null
+++ b/makefu/2configs/deployment/rss/rss.euer.krebsco.de.nix
@@ -0,0 +1,30 @@
+{ pkgs, lib, config, ... }:
+let
+ fqdn = "rss.euer.krebsco.de";
+ ratt-path = "/var/lib/ratt/";
+in {
+ systemd.tmpfiles.rules = ["d ${ratt-path} 0750 nginx nginx - -" ];
+ services.tt-rss = {
+ enable = true;
+ virtualHost = fqdn;
+ selfUrlPath = "https://${fqdn}";
+ };
+
+ state = [ config.services.postgresqlBackup.location ];
+
+ services.postgresqlBackup = {
+ enable = true;
+ databases = [ config.services.tt-rss.database.name ];
+ };
+ systemd.services.postgresqlBackup-tt_rss.serviceConfig.SupplementaryGroups = [ "download" ];
+
+ services.nginx.virtualHosts."${fqdn}" = {
+ enableACME = true;
+ forceSSL = true;
+ locations."/ratt/" = {
+ alias = ratt-path;
+ extraConfig = "autoindex on;";
+ };
+ };
+}
+