summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/deps/aresponses.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bureautomation/deps/aresponses.nix')
-rw-r--r--makefu/2configs/bureautomation/deps/aresponses.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/deps/aresponses.nix b/makefu/2configs/bureautomation/deps/aresponses.nix
new file mode 100644
index 00000000..9e64d2f6
--- /dev/null
+++ b/makefu/2configs/bureautomation/deps/aresponses.nix
@@ -0,0 +1,38 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+# propagatedBuildInputs
+, aiohttp
+# buildInputs
+, pytest
+, pytest-asyncio
+}:
+
+buildPythonPackage rec {
+ pname = "aresponses";
+ version = "1.1.1";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "d1d6ef52b9a97142d106688cf9b112602ef3dc66f6368de8f91f47241d8cfc9c";
+ };
+
+ propagatedBuildInputs = [
+ aiohttp
+ ];
+
+ buildInputs = [
+ pytest
+ pytest-asyncio
+ ];
+
+ # tests only distributed via git repository, not pypi
+ doCheck = false;
+
+ meta = with lib; {
+ description = "Asyncio testing server";
+ homepage = "https://github.com/circleup/aresponses";
+ license = licenses.mit;
+ maintainers = [ maintainers.makefu ];
+ };
+}