summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/wbob/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/wbob/config.nix')
-rw-r--r--makefu/1systems/wbob/config.nix37
1 files changed, 12 insertions, 25 deletions
diff --git a/makefu/1systems/wbob/config.nix b/makefu/1systems/wbob/config.nix
index e1d66a2f..f2311fb5 100644
--- a/makefu/1systems/wbob/config.nix
+++ b/makefu/1systems/wbob/config.nix
@@ -11,10 +11,10 @@ in {
<stockholm/makefu>
<stockholm/makefu/2configs/zsh-user.nix>
<stockholm/makefu/2configs/tools/core.nix>
- <stockholm/makefu/2configs/disable_v6.nix>
- # <stockholm/makefu/2configs/tools/core-gui.nix>
- # <stockholm/makefu/2configs/tools/extra-gui.nix>
- # <stockholm/makefu/2configs/tools/media.nix>
+ # <stockholm/makefu/2configs/disable_v6.nix>
+ <stockholm/makefu/2configs/tools/core-gui.nix>
+ <stockholm/makefu/2configs/tools/extra-gui.nix>
+ <stockholm/makefu/2configs/tools/media.nix>
<stockholm/makefu/2configs/virtualisation/libvirt.nix>
<stockholm/makefu/2configs/tinc/retiolum.nix>
<stockholm/makefu/2configs/mqtt.nix>
@@ -33,9 +33,6 @@ in {
<stockholm/makefu/2configs/share/wbob.nix>
<stockholm/makefu/2configs/bluetooth-mpd.nix>
- {
- users.users.makefu.extraGroups = [ "pulse" ];
- }
# Sensors
<stockholm/makefu/2configs/stats/telegraf>
@@ -46,10 +43,16 @@ in {
<stockholm/makefu/2configs/deployment/led-fader.nix>
<stockholm/makefu/2configs/hw/mceusb.nix>
# <stockholm/makefu/2configs/stats/telegraf/bamstats.nix>
+ { environment.systemPackages = [ pkgs.vlc ]; }
-
-
+ {
+ # Risikoübernahme
+ nixpkgs.config.permittedInsecurePackages = [
+ "homeassistant-0.77.2"
+ ];
+ }
<stockholm/makefu/2configs/deployment/bureautomation>
+ <stockholm/makefu/2configs/deployment/bureautomation/mpd.nix>
<stockholm/makefu/2configs/deployment/bureautomation/hass.nix>
(let
collectd-port = 25826;
@@ -174,20 +177,4 @@ in {
fsType = "ext4";
};
};
-
- # DualHead on NUC
- # TODO: update synergy package with these extras (username)
- # TODO: add crypto layer
- systemd.services."synergy-client" = {
- environment.DISPLAY = ":0";
- serviceConfig.User = user;
- };
-
- services.synergy = {
- client = {
- enable = true;
- screenName = "wbob";
- serverAddress = "x.r";
- };
- };
}