summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/cake/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/cake/config.nix')
-rw-r--r--makefu/1systems/cake/config.nix41
1 files changed, 3 insertions, 38 deletions
diff --git a/makefu/1systems/cake/config.nix b/makefu/1systems/cake/config.nix
index 2491352e..e40042b2 100644
--- a/makefu/1systems/cake/config.nix
+++ b/makefu/1systems/cake/config.nix
@@ -2,6 +2,7 @@
{
imports = [
<stockholm/makefu>
+ ./hardware-config.nix
<stockholm/makefu/2configs/tools/core.nix>
# configure your hw:
# <stockholm/makefu/2configs/save-diskspace.nix>
@@ -11,46 +12,10 @@
tinc.retiolum.enable = true;
build.host = config.krebs.hosts.cake;
};
- boot.loader.grub.enable = false;
- boot.loader.generic-extlinux-compatible.enable = true;
- boot.kernelPackages = pkgs.linuxPackages_latest;
- boot.kernelParams = ["cma=32M" "console=ttyS0,115200n8" "console=tty0" ];
- programs.info.enable = false;
- programs.man.enable = false;
+ documentation.info.enable = false;
+ documentation.man.enable = false;
services.nixosManual.enable = false;
- boot.tmpOnTmpfs = lib.mkForce false;
sound.enable = false;
- hardware.enableRedistributableFirmware = true;
- hardware.firmware = [
- (pkgs.stdenv.mkDerivation {
- name = "broadcom-rpi3-rest";
- src = pkgs.fetchurl {
- url = "https://raw.githubusercontent.com/RPi-Distro/firmware-nonfree/54bab3d/brcm80211/brcm/brcmfmac43430-sdio.txt";
- sha256 = "19bmdd7w0xzybfassn7x4rb30l70vynnw3c80nlapna2k57xwbw7";
- };
- phases = [ "installPhase" ];
- installPhase = ''
- mkdir -p $out/lib/firmware/brcm
- cp $src $out/lib/firmware/brcm/brcmfmac43430-sdio.txt
- '';
- })
- ];
- networking.wireless.enable = true;
- users.extraUsers.root.openssh.authorizedKeys.keys = [
- config.krebs.users.Mic92.pubkey
- ];
-
-# File systems configuration for using the installer's partition layout
- fileSystems = {
- "/boot" = {
- device = "/dev/disk/by-label/NIXOS_BOOT";
- fsType = "vfat";
- };
- "/" = {
- device = "/dev/disk/by-label/NIXOS_SD";
- fsType = "ext4";
- };
- };
}