summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix19
1 files changed, 16 insertions, 3 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 67a0c6f1..32b4541a 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -18,9 +18,6 @@ rec {
type = label;
default = config._module.args.name;
};
- cores = mkOption {
- type = uint;
- };
nets = mkOption {
type = attrsOf net;
default = {};
@@ -149,6 +146,14 @@ rec {
}.${config._module.args.name} or {
default = "${ip4.config.addr}/32";
});
+ prefixLength = mkOption ({
+ type = uint;
+ } // {
+ retiolum.default = 16;
+ wiregrill.default = 16;
+ }.${config._module.args.name} or {
+ default = 32;
+ });
};
}));
default = null;
@@ -168,6 +173,14 @@ rec {
}.${config._module.args.name} or {
default = "${ip6.config.addr}/128";
});
+ prefixLength = mkOption ({
+ type = uint;
+ } // {
+ retiolum.default = 32;
+ wiregrill.default = 32;
+ }.${config._module.args.name} or {
+ default = 128;
+ });
};
}));
default = null;