summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 17c1688f..9001bc7c 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -86,6 +86,12 @@ rec {
type = nullOr ssh-privkey;
default = null;
};
+
+ syncthing.id = mkOption {
+ # TODO syncthing id type
+ type = nullOr string;
+ default = null;
+ };
};
});
@@ -539,7 +545,7 @@ rec {
# POSIX.1‐2013, 3.278 Portable Filename Character Set
filename = mkOptionType {
name = "POSIX filename";
- check = test "([0-9A-Za-z._])[0-9A-Za-z._-]*";
+ check = test "[0-9A-Za-z._][0-9A-Za-z._-]*";
merge = mergeOneOption;
};