summaryrefslogtreecommitdiffstats
path: root/lass/krops.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/krops.nix')
-rw-r--r--lass/krops.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/lass/krops.nix b/lass/krops.nix
index 12652216..c1fbe284 100644
--- a/lass/krops.nix
+++ b/lass/krops.nix
@@ -5,11 +5,6 @@
pkgs
;
- host-source = if lib.pathExists (./. + "/1systems/${name}/source.nix") then
- import (./. + "/1systems/${name}/source.nix") { inherit lib pkgs; }
- else
- {}
- ;
source = { test }: lib.evalSource ([
(krebs-source { test = test; })
@@ -24,7 +19,12 @@
};
};
}
- ] ++ (lib.optional (! test) host-source));
+ (if lib.pathExists (./. + "/1systems/${name}/source.nix") then
+ import (./. + "/1systems/${name}/source.nix") { inherit lib pkgs test; }
+ else
+ {}
+ )
+ ]);
in {