summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/nichtparasoup/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/5pkgs/nichtparasoup/default.nix')
-rw-r--r--lass/5pkgs/nichtparasoup/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/lass/5pkgs/nichtparasoup/default.nix b/lass/5pkgs/nichtparasoup/default.nix
new file mode 100644
index 00000000..cf34c683
--- /dev/null
+++ b/lass/5pkgs/nichtparasoup/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, pkgs, ... }:
+let
+ py = pkgs.python3Packages.python.withPackages (p: [
+ p.werkzeug
+ p.beautifulsoup4
+ ]);
+ src = pkgs.fetchFromGitHub {
+ owner = "k4cg";
+ repo = "nichtparasoup";
+ rev = "cf164b5";
+ sha256 = "09bwh76agp14j8rv7bp47jcwhffc1b0bak0ikvzxyphph5lyidk9";
+ };
+ patchedSrc = stdenv.mkDerivation {
+ name = "nichtparasoup";
+ inherit src;
+ patches = [ ./exception.patch ];
+ phases = [ "unpackPhase" "patchPhase" "installPhase" ];
+ installPhase = ''
+ mkdir -p $out
+ cp -r * $out/
+ '';
+ };
+in pkgs.writeDashBin "nichtparasoup" ''
+ ${py}/bin/python ${patchedSrc}/nichtparasoup.py "$@"
+''