summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/acronym
diff options
context:
space:
mode:
Diffstat (limited to 'lass/5pkgs/acronym')
-rw-r--r--lass/5pkgs/acronym/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/lass/5pkgs/acronym/default.nix b/lass/5pkgs/acronym/default.nix
new file mode 100644
index 00000000..53d5d015
--- /dev/null
+++ b/lass/5pkgs/acronym/default.nix
@@ -0,0 +1,13 @@
+{ pkgs, ... }:
+
+pkgs.writeScriptBin "acronym" ''
+ #! ${pkgs.bash}/bin/bash
+
+ acro=$1
+
+ curl -s http://www.acronymfinder.com/$acro.html \
+ | grep 'class="result-list__body__rank"' \
+ | sed 's/.*title="\([^"]*\)".*/\1/' \
+ | sed 's/^.* - //' \
+ | sed "s/'/'/g"
+''