summaryrefslogtreecommitdiffstats
path: root/lass/3modules/xresources.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/3modules/xresources.nix')
-rw-r--r--lass/3modules/xresources.nix58
1 files changed, 0 insertions, 58 deletions
diff --git a/lass/3modules/xresources.nix b/lass/3modules/xresources.nix
deleted file mode 100644
index 017dbff2..00000000
--- a/lass/3modules/xresources.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-#TODO:
-#prefix with Attribute Name
-#ex: urxvt
-
-with builtins;
-with lib;
-
-
-let
-
- inherit (pkgs) writeScript writeText;
-
-in
-
-{
-
- options = {
- services.xresources.enable = mkOption {
- type = types.bool;
- default = false;
- description = ''
- Whether to enable the automatic loading of Xresources definitions at display-manager start;
- '';
- };
-
- services.xresources.resources = mkOption {
- default = {};
- type = types.attrsOf types.str;
- example = {
- urxvt = ''
- URxvt*scrollBar: false
- URxvt*urgentOnBell: true
- '';
- };
- description = ''
- Xresources definitions.
- '';
- };
- };
-
- config =
- let
- cfg = config.services.xresources;
- xres = writeText "xresources" (concatStringsSep "\n" (attrValues cfg.resources));
-
- in mkIf cfg.enable {
- services.xserver.displayManager.sessionCommands = ''
- ${pkgs.xorg.xrdb}/bin/xrdb -merge ${xres}
- '';
- environment.systemPackages = [
- (pkgs.writeDashBin "updateXresources" ''
- ${pkgs.xorg.xrdb}/bin/xrdb -merge ${xres}
- '')
- ];
- };
-}