summaryrefslogtreecommitdiffstats
path: root/lass/3modules/sync-containers.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/3modules/sync-containers.nix')
-rw-r--r--lass/3modules/sync-containers.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/lass/3modules/sync-containers.nix b/lass/3modules/sync-containers.nix
index 990e3212..ca81458a 100644
--- a/lass/3modules/sync-containers.nix
+++ b/lass/3modules/sync-containers.nix
@@ -97,9 +97,10 @@ in {
})) cfg.containers);
krebs.permown = (mapAttrs' (_: ctr: nameValuePair "${(paths ctr.name).${ctr.format}}" ({
- owner = "root";
- group = "syncthing";
- umask = "0007";
+ file-mode = "u+rw";
+ directory-mode = "u+rwx";
+ owner = "syncthing";
+ keepGoing = false;
})) cfg.containers);
systemd.services = mapAttrs' (n: ctr: nameValuePair "containers@${ctr.name}" ({