summaryrefslogtreecommitdiffstats
path: root/lass/3modules/hosts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/3modules/hosts.nix')
-rw-r--r--lass/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/lass/3modules/hosts.nix b/lass/3modules/hosts.nix
new file mode 100644
index 00000000..f2ff10c0
--- /dev/null
+++ b/lass/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with config.krebs.lib;
+
+{
+ options.lass.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "lass")
+ config.krebs.hosts;
+ };
+}