summaryrefslogtreecommitdiffstats
path: root/lass/3modules/hass.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/3modules/hass.nix')
-rw-r--r--lass/3modules/hass.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/lass/3modules/hass.nix b/lass/3modules/hass.nix
index 30158e78..96521aaa 100644
--- a/lass/3modules/hass.nix
+++ b/lass/3modules/hass.nix
@@ -22,6 +22,22 @@ in {
};
in valueType;
};
+ love = mkOption {
+ default = {};
+ type = with lib.types; let
+ valueType = nullOr (oneOf [
+ bool
+ int
+ float
+ str
+ (attrsOf valueType)
+ (listOf valueType)
+ ]) // {
+ description = "Yaml value";
+ emptyValue.value = {};
+ };
+ in valueType;
+ };
};
config =
@@ -29,6 +45,7 @@ in {
mkIf (cfg.config != {})
{
services.home-assistant.config = cfg.config;
+ # services.home-assistant.lovelaceConfig = cfg.love;
};
}