summaryrefslogtreecommitdiffstats
path: root/lass/2configs/weron/client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/weron/client.nix')
-rw-r--r--lass/2configs/weron/client.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/lass/2configs/weron/client.nix b/lass/2configs/weron/client.nix
new file mode 100644
index 00000000..55bc8a0d
--- /dev/null
+++ b/lass/2configs/weron/client.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+{
+ systemd.services.weron = {
+ wantedBy = [ "multi-user.target" ];
+ environment = {
+ WERON_RADDR = "ws://lassul.us:23420/";
+ };
+ serviceConfig = {
+ ExecStart = pkgs.writers.writeDash "weron" ''
+ ${pkgs.weron}/bin/weron vpn ip \
+ --community krebs \
+ --password aidsballs \
+ --key aidsballs \
+ --ips 10.249.1.0/24 \
+ --verbose 7 \
+ --dev weron
+ '';
+ };
+ };
+}