summaryrefslogtreecommitdiffstats
path: root/lass/2configs/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/vim.nix')
-rw-r--r--lass/2configs/vim.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/lass/2configs/vim.nix b/lass/2configs/vim.nix
index 36ce3d74..4a748b1e 100644
--- a/lass/2configs/vim.nix
+++ b/lass/2configs/vim.nix
@@ -51,7 +51,7 @@ let
filetype plugin indent on
set t_Co=256
- colorscheme hack
+ colorscheme dim
syntax on
au Syntax * syn match Garbage containedin=ALL /\s\+$/
@@ -170,6 +170,15 @@ let
hi diffRemoved ctermfg=009
'';
})))
+ (pkgs.vimUtils.buildVimPlugin {
+ name = "vim-dim-1.1.0";
+ src = pkgs.fetchFromGitHub {
+ owner = "jeffkreeftmeijer";
+ repo = "vim-dim";
+ rev = "1.1.0";
+ sha256 = "sha256-lyTZUgqUEEJRrzGo1FD8/t8KBioPrtB3MmGvPeEVI/g=";
+ };
+ })
((rtp: rtp // { inherit rtp; }) (pkgs.writeTextFile (let
name = "vim";
in {