summaryrefslogtreecommitdiffstats
path: root/lass/2configs/hw/tp-x220.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/hw/tp-x220.nix')
-rw-r--r--lass/2configs/hw/tp-x220.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/lass/2configs/hw/tp-x220.nix b/lass/2configs/hw/tp-x220.nix
deleted file mode 100644
index 9be0b6bd..00000000
--- a/lass/2configs/hw/tp-x220.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-{
- imports = [
- ../smartd.nix
- ];
- networking.wireless.enable = lib.mkDefault true;
-
- hardware.enableAllFirmware = true;
- nixpkgs.config.allowUnfree = true;
-
- hardware.cpu.intel.updateMicrocode = true;
-
- zramSwap.enable = true;
- zramSwap.numDevices = 2;
-
- hardware.trackpoint = {
- enable = true;
- sensitivity = 220;
- speed = 0;
- emulateWheel = true;
- };
-
- services.tlp.enable = true;
- services.tlp.extraConfig = ''
- # BUG: http://linrunner.de/en/tlp/docs/tlp-faq.html#erratic-battery
- #START_CHARGE_THRESH_BAT0=80
- STOP_CHARGE_THRESH_BAT0=95
-
- CPU_SCALING_GOVERNOR_ON_AC=performance
- CPU_SCALING_GOVERNOR_ON_BAT=ondemand
- CPU_MIN_PERF_ON_AC=0
- CPU_MAX_PERF_ON_AC=100
- CPU_MIN_PERF_ON_BAT=0
- CPU_MAX_PERF_ON_BAT=30
- '';
-
- boot = {
- kernelModules = [ "kvm-intel" "acpi_call" "tpm-rng" ];
- extraModulePackages = [ config.boot.kernelPackages.tp_smapi ];
- kernelParams = [ "acpi_backlight=none" ];
- };
-
- hardware.opengl.extraPackages = [
- pkgs.vaapiIntel
- pkgs.vaapiVdpau
- ];
-
- security.rngd.enable = true;
-
- services.xserver.synaptics = {
- enable = true;
- horizEdgeScroll = false;
- horizontalScroll = false;
- vertEdgeScroll = false;
- maxSpeed = "0.1";
- minSpeed = "0.01";
- tapButtons = false;
- };
-}