summaryrefslogtreecommitdiffstats
path: root/lass/2configs/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/git.nix')
-rw-r--r--lass/2configs/git.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lass/2configs/git.nix b/lass/2configs/git.nix
index d3f5d1f3..eb606037 100644
--- a/lass/2configs/git.nix
+++ b/lass/2configs/git.nix
@@ -80,7 +80,7 @@ let
public = true;
};
- make-restricted-repo = name: { collaborators ? [], announce ? false, ... }: {
+ make-restricted-repo = name: { collaborators ? [], announce ? false, hooks ? {}, ... }: {
inherit collaborators name;
public = false;
hooks = optionalAttrs announce {
@@ -93,7 +93,7 @@ let
# TODO define branches in some kind of option per repo
branches = [ "master" "staging*" ];
};
- };
+ } // hooks;
};
make-rules =