summaryrefslogtreecommitdiffstats
path: root/lass/2configs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/default.nix')
-rw-r--r--lass/2configs/default.nix24
1 files changed, 9 insertions, 15 deletions
diff --git a/lass/2configs/default.nix b/lass/2configs/default.nix
index eb38d0e9..91922e5c 100644
--- a/lass/2configs/default.nix
+++ b/lass/2configs/default.nix
@@ -19,10 +19,9 @@ with import <stockholm/lib>;
users.extraUsers = {
root = {
openssh.authorizedKeys.keys = [
- config.krebs.users.lass-mors.pubkey
+ config.krebs.users.lass.pubkey
config.krebs.users.lass-blue.pubkey
config.krebs.users.lass-green.pubkey
- config.krebs.users.lass-yubikey.pubkey
];
};
mainUser = {
@@ -35,25 +34,17 @@ with import <stockholm/lib>;
isNormalUser = true;
extraGroups = [
"audio"
+ "video"
"fuse"
"wheel"
];
openssh.authorizedKeys.keys = [
- config.krebs.users.lass-mors.pubkey
+ config.krebs.users.lass.pubkey
config.krebs.users.lass-blue.pubkey
config.krebs.users.lass-green.pubkey
- config.krebs.users.lass-yubikey.pubkey
- ];
- };
- nix = {
- isNormalUser = true;
- uid = genid_uint31 "nix";
- openssh.authorizedKeys.keys = [
- config.krebs.hosts.mors.ssh.pubkey
];
};
};
- nix.trustedUsers = ["nix"];
}
{
environment.variables = {
@@ -70,7 +61,7 @@ with import <stockholm/lib>;
{
#for sshuttle
environment.systemPackages = [
- pkgs.pythonPackages.python
+ pkgs.python3Packages.python
];
}
];
@@ -89,8 +80,6 @@ with import <stockholm/lib>;
services.timesyncd.enable = mkForce true;
- boot.tmpOnTmpfs = true;
-
# multiple-definition-problem when defining environment.variables.EDITOR
environment.extraInit = ''
EDITOR=vim
@@ -102,6 +91,7 @@ with import <stockholm/lib>;
#stockholm
deploy
git
+ git-preview
gnumake
jq
@@ -126,6 +116,7 @@ with import <stockholm/lib>;
file
hashPassword
kpaste
+ cyberlocker-tools
pciutils
pop
q
@@ -187,6 +178,7 @@ with import <stockholm/lib>;
services.journald.extraConfig = ''
SystemMaxUse=1G
RuntimeMaxUse=128M
+ Storage=persistent
'';
krebs.iptables = {
@@ -225,5 +217,7 @@ with import <stockholm/lib>;
# use 24:00 time format, the default got sneakily changed around 20.03
i18n.defaultLocale = mkDefault "C.UTF-8";
+ time.timeZone = mkDefault"Europe/Berlin";
+
system.stateVersion = mkDefault "20.03";
}