summaryrefslogtreecommitdiffstats
path: root/lass/1systems/prism/physical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/prism/physical.nix')
-rw-r--r--lass/1systems/prism/physical.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/lass/1systems/prism/physical.nix b/lass/1systems/prism/physical.nix
index ebc80411..2260aa64 100644
--- a/lass/1systems/prism/physical.nix
+++ b/lass/1systems/prism/physical.nix
@@ -9,6 +9,7 @@
boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "sd_mod" ];
boot.kernelModules = [ "kvm-intel" ];
+ boot.swraid.enable = true;
fileSystems."/" = {
device = "rpool/root/nixos";
@@ -60,11 +61,6 @@
fsType = "zfs";
};
- fileSystems."/home/xanf" = {
- device = "/dev/disk/by-id/wwn-0x500a07511becb076";
- fsType = "ext4";
- };
-
# silence mdmonitor.service failures
# https://github.com/NixOS/nixpkgs/issues/72394
environment.etc."mdadm.conf".text = ''
@@ -80,7 +76,7 @@
# we don't pay for power there and this might solve a problem we observed at least once
# https://www.thomas-krenn.com/de/wiki/PCIe_Bus_Error_Status_00001100_beheben
- boot.kernelParams = [ "pcie_aspm=off" "net.ifnames=0" ];
+ boot.kernelParams = [ "pcie_aspm=off" "net.ifnames=0" "nomodeset" ];
networking.dhcpcd.enable = false;