summaryrefslogtreecommitdiffstats
path: root/lass/1systems/hilum/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/hilum/config.nix')
-rw-r--r--lass/1systems/hilum/config.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/lass/1systems/hilum/config.nix b/lass/1systems/hilum/config.nix
new file mode 100644
index 00000000..998fa147
--- /dev/null
+++ b/lass/1systems/hilum/config.nix
@@ -0,0 +1,28 @@
+{ config, ... }:
+{
+ imports = [
+ <stockholm/lass>
+
+ <stockholm/lass/2configs/retiolum.nix>
+ <stockholm/lass/2configs/baseX.nix>
+ <stockholm/lass/2configs/browsers.nix>
+ <stockholm/lass/2configs/programs.nix>
+ <stockholm/lass/2configs/network-manager.nix>
+ <stockholm/lass/2configs/mail.nix>
+ <stockholm/lass/2configs/syncthing.nix>
+ ];
+
+ krebs.build.host = config.krebs.hosts.hilum;
+
+ boot.loader.grub.extraEntries = ''
+ menuentry "grml" {
+ iso_path=/isos/grml.iso
+ export iso_path
+ search --set=root --file $iso_path
+ loopback loop $iso_path
+ root=(loop)
+ configfile /boot/grub/loopback.cfg
+ loopback --delete loop
+ }
+ '';
+}