summaryrefslogtreecommitdiffstats
path: root/lass/1systems/dishfire/physical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/dishfire/physical.nix')
-rw-r--r--lass/1systems/dishfire/physical.nix44
1 files changed, 13 insertions, 31 deletions
diff --git a/lass/1systems/dishfire/physical.nix b/lass/1systems/dishfire/physical.nix
index 64e3904e..ca013132 100644
--- a/lass/1systems/dishfire/physical.nix
+++ b/lass/1systems/dishfire/physical.nix
@@ -1,39 +1,21 @@
-{ config, lib, pkgs, ... }:
+{ config, lib, pkgs, modulesPath, ... }:
+
{
imports = [
./config.nix
- <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
- ];
-
- boot.loader.grub = {
- device = "/dev/vda";
- splashImage = null;
- };
-
- boot.initrd.availableKernelModules = [
- "ata_piix"
- "ehci_pci"
- "uhci_hcd"
- "virtio_pci"
- "virtio_blk"
+ (modulesPath + "/profiles/qemu-guest.nix")
];
- fileSystems."/" = {
- device = "/dev/mapper/pool-nix";
- fsType = "ext4";
- };
+ boot.initrd.availableKernelModules = [ "ata_piix" "virtio_pci" "xhci_pci" "sd_mod" "sr_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+ boot.loader.grub.devices = [ "/dev/sda" ];
- fileSystems."/srv/http" = {
- device = "/dev/pool/srv_http";
- fsType = "ext4";
- };
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/84053adc-49bc-4e02-8a19-3838bf3a43fd";
+ fsType = "ext4";
+ };
- fileSystems."/boot" = {
- device = "/dev/vda1";
- fsType = "ext4";
- };
- fileSystems."/bku" = {
- device = "/dev/pool/bku";
- fsType = "ext4";
- };
+ swapDevices = [ ];
}