summaryrefslogtreecommitdiffstats
path: root/lass/1systems/dishfire/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/dishfire/config.nix')
-rw-r--r--lass/1systems/dishfire/config.nix53
1 files changed, 0 insertions, 53 deletions
diff --git a/lass/1systems/dishfire/config.nix b/lass/1systems/dishfire/config.nix
index 3d5f3218..b814d718 100644
--- a/lass/1systems/dishfire/config.nix
+++ b/lass/1systems/dishfire/config.nix
@@ -4,59 +4,6 @@
imports = [
<stockholm/lass>
<stockholm/lass/2configs/retiolum.nix>
- <stockholm/lass/2configs/git.nix>
- {
- networking.dhcpcd.allowInterfaces = [
- "enp*"
- "eth*"
- "ens*"
- ];
- }
- {
- sound.enable = false;
- }
- {
- environment.systemPackages = with pkgs; [
- mk_sql_pair
- ];
- }
- {
- imports = [
- <stockholm/lass/2configs/websites/fritz.nix>
- ];
- krebs.iptables.tables.filter.INPUT.rules = [
- { predicate = "-p tcp --dport http"; target = "ACCEPT"; }
- { predicate = "-p tcp --dport https"; target = "ACCEPT"; }
- ];
- }
- {
- #TODO: abstract & move to own file
- krebs.exim-smarthost = {
- enable = true;
- relay_from_hosts = map (host: host.nets.retiolum.ip4.addr) [
- config.krebs.hosts.mors
- config.krebs.hosts.uriel
- ];
- system-aliases = [
- { from = "mailer-daemon"; to = "postmaster"; }
- { from = "postmaster"; to = "root"; }
- { from = "nobody"; to = "root"; }
- { from = "hostmaster"; to = "root"; }
- { from = "usenet"; to = "root"; }
- { from = "news"; to = "root"; }
- { from = "webmaster"; to = "root"; }
- { from = "www"; to = "root"; }
- { from = "ftp"; to = "root"; }
- { from = "abuse"; to = "root"; }
- { from = "noc"; to = "root"; }
- { from = "security"; to = "root"; }
- { from = "root"; to = "lass"; }
- ];
- };
- krebs.iptables.tables.filter.INPUT.rules = [
- { predicate = "-p tcp --dport smtp"; target = "ACCEPT"; }
- ];
- }
];
krebs.build.host = config.krebs.hosts.dishfire;