summaryrefslogtreecommitdiffstats
path: root/lass/1systems/blue/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/blue/config.nix')
-rw-r--r--lass/1systems/blue/config.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/lass/1systems/blue/config.nix b/lass/1systems/blue/config.nix
index aef055cf..a84bb37f 100644
--- a/lass/1systems/blue/config.nix
+++ b/lass/1systems/blue/config.nix
@@ -12,6 +12,14 @@ with import <stockholm/lib>;
krebs.build.host = config.krebs.hosts.blue;
+ environment.shellAliases = {
+ deploy = pkgs.writeDash "deploy" ''
+ set -eu
+ export SYSTEM="$1"
+ $(nix-build $HOME/stockholm/lass/krops.nix --no-out-link --argstr name "$SYSTEM" -A deploy)
+ '';
+ };
+
networking.nameservers = [ "1.1.1.1" ];
lass.restic = genAttrs [