summaryrefslogtreecommitdiffstats
path: root/krebs/krops.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/krops.nix')
-rw-r--r--krebs/krops.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/krebs/krops.nix b/krebs/krops.nix
index c71e6057..5378d6fb 100644
--- a/krebs/krops.nix
+++ b/krebs/krops.nix
@@ -55,14 +55,9 @@
target = "root@${name}/var/src";
};
- # usage: $(nix-build --no-out-link --argstr name HOSTNAME -A test)
- test = pkgs.krops.writeTest "${name}-test" {
+ # usage: $(nix-build --no-out-link --argstr name HOSTNAME --argstr target PATH -A test)
+ test = { target }: pkgs.krops.writeTest "${name}-test" {
+ inherit target;
source = source { test = true; };
- target = "${lib.getEnv "HOME"}/tmp/${name}-krops-test-src";
- };
-
- ci = pkgs.krops.writeTest "${name}-test" {
- source = source { test = true; };
- target = "${lib.getEnv "HOME"}/stockholm-build";
};
}