summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/urix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/urix.nix')
-rw-r--r--krebs/5pkgs/simple/urix.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/urix.nix b/krebs/5pkgs/simple/urix.nix
new file mode 100644
index 00000000..c0db8c97
--- /dev/null
+++ b/krebs/5pkgs/simple/urix.nix
@@ -0,0 +1,15 @@
+let lib = import <stockholm/lib>; in
+{ pkgs }:
+
+# urix - URI eXtractor
+# Extract all the URIs from standard input and write them to standard output!
+# usage: urix < SOMEFILE
+
+pkgs.execBin "urix" {
+ filename = "${pkgs.gnugrep}/bin/grep";
+ argv = [
+ "urix"
+ "-Eo"
+ "\\b${lib.uri.posix-extended-regex}\\b"
+ ];
+}