summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/solanum/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/solanum/default.nix')
-rw-r--r--krebs/5pkgs/simple/solanum/default.nix62
1 files changed, 0 insertions, 62 deletions
diff --git a/krebs/5pkgs/simple/solanum/default.nix b/krebs/5pkgs/simple/solanum/default.nix
deleted file mode 100644
index 3fa765c9..00000000
--- a/krebs/5pkgs/simple/solanum/default.nix
+++ /dev/null
@@ -1,62 +0,0 @@
-{ lib, stdenv
-, fetchFromGitHub
-, autoreconfHook
-, pkg-config
-, bison
-, flex
-, openssl
-, sqlite
-, lksctp-tools
-}:
-
-stdenv.mkDerivation rec {
- pname = "solanum";
- version = "unstable-2021-04-27";
-
- src = fetchFromGitHub {
- owner = "solanum-ircd";
- repo = pname;
- rev = "3ff5a12e75662e9a642f2a4364797bd361eb0925";
- sha256 = "14ywmfdv8cncbyg08y2qdis00kwg8lvhkcgj185is67smh0qf88f";
- };
-
- patches = [
- ./dont-create-logdir.patch
- ];
-
- configureFlags = [
- "--enable-epoll"
- "--enable-ipv6"
- "--enable-openssl=${openssl.dev}"
- "--with-program-prefix=solanum-"
- "--localstatedir=/var/lib"
- "--with-rundir=/run"
- "--with-logdir=/var/log"
- ] ++ lib.optionals (stdenv.isLinux) [
- "--enable-sctp=${lksctp-tools.out}/lib"
- ];
-
- nativeBuildInputs = [
- autoreconfHook
- bison
- flex
- pkg-config
- ];
-
- buildInputs = [
- openssl
- sqlite
- ];
-
- doCheck = !stdenv.isDarwin;
-
- enableParallelBuilding = true;
-
- meta = with lib; {
- description = "An IRCd for unified networks";
- homepage = "https://github.com/solanum-ircd/solanum";
- license = licenses.gpl2Only;
- maintainers = with maintainers; [ hexa ];
- platforms = platforms.unix;
- };
-}