summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/hashPassword/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/hashPassword/default.nix')
-rw-r--r--krebs/5pkgs/simple/hashPassword/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/hashPassword/default.nix b/krebs/5pkgs/simple/hashPassword/default.nix
new file mode 100644
index 00000000..3da65ad7
--- /dev/null
+++ b/krebs/5pkgs/simple/hashPassword/default.nix
@@ -0,0 +1,15 @@
+{ lib, pkgs, ... }:
+
+pkgs.writeDashBin "hashPassword" ''
+ # usage: hashPassword
+ set -euf
+
+ export PATH=${lib.makeBinPath (with pkgs; [
+ coreutils
+ mkpasswd
+ openssl
+ ])}
+
+ salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
+ exec mkpasswd -m sha-512 -S "$salt"
+''