summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell')
-rw-r--r--krebs/5pkgs/haskell/brockman.nix26
-rw-r--r--krebs/5pkgs/haskell/brockman/default.nix26
2 files changed, 26 insertions, 26 deletions
diff --git a/krebs/5pkgs/haskell/brockman.nix b/krebs/5pkgs/haskell/brockman.nix
deleted file mode 100644
index 5f1166a2..00000000
--- a/krebs/5pkgs/haskell/brockman.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ mkDerivation, aeson, aeson-pretty, base, bloomfilter, bytestring
-, case-insensitive, conduit, containers, directory, feed, filepath
-, hslogger, html-entity, http-client, irc-conduit, lens, network
-, optparse-applicative, random, safe, stdenv, text, time, timerep
-, wreq
-, fetchFromGitHub
-}:
-mkDerivation rec {
- pname = "brockman";
- version = "3.2.3";
- src = fetchFromGitHub {
- owner = "kmein";
- repo = "brockman";
- rev = version;
- sha256 = "1qbjbf0l1ikfzmvky4cnvv7nlcwi2in4afliifh618j0a4f7j427";
- };
- isLibrary = false;
- isExecutable = true;
- executableHaskellDepends = [
- aeson aeson-pretty base bloomfilter bytestring case-insensitive
- conduit containers directory feed filepath hslogger html-entity
- http-client irc-conduit lens network optparse-applicative random
- safe text time timerep wreq
- ];
- license = stdenv.lib.licenses.mit;
-}
diff --git a/krebs/5pkgs/haskell/brockman/default.nix b/krebs/5pkgs/haskell/brockman/default.nix
new file mode 100644
index 00000000..92051a02
--- /dev/null
+++ b/krebs/5pkgs/haskell/brockman/default.nix
@@ -0,0 +1,26 @@
+{ mkDerivation, aeson, aeson-pretty, base, bytestring
+, case-insensitive, conduit, containers, directory, feed, filepath
+, hashable, hslogger, html-entity, http-client, irc-conduit, lens
+, lrucache, lrucaching, network, optparse-applicative, random, safe
+, stdenv, text, time, timerep, wreq
+, fetchFromGitHub
+}:
+mkDerivation rec {
+ pname = "brockman";
+ version = "3.4.0";
+ src = fetchFromGitHub {
+ owner = "kmein";
+ repo = "brockman";
+ rev = version;
+ sha256 = "02nval6a9xcddj6znzxvcb8g6klzjydj1lb4ych64i9mr4a8jvic";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson aeson-pretty base bytestring case-insensitive conduit
+ containers directory feed filepath hashable hslogger html-entity
+ http-client irc-conduit lens lrucache lrucaching network
+ optparse-applicative random safe text time timerep wreq
+ ];
+ license = stdenv.lib.licenses.mit;
+}