summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell')
-rw-r--r--krebs/5pkgs/haskell/blessings.nix4
-rw-r--r--krebs/5pkgs/haskell/much.nix29
-rw-r--r--krebs/5pkgs/haskell/reaktor2.nix6
3 files changed, 34 insertions, 5 deletions
diff --git a/krebs/5pkgs/haskell/blessings.nix b/krebs/5pkgs/haskell/blessings.nix
index 19f8da19..97e4a717 100644
--- a/krebs/5pkgs/haskell/blessings.nix
+++ b/krebs/5pkgs/haskell/blessings.nix
@@ -7,8 +7,8 @@ with import <stockholm/lib>;
sha256 = "1k908zap3694fcxdk4bb29s54b0lhdh557y10ybjskfwnym7szn1";
};
"18.09" = {
- version = "1.3.0";
- sha256 = "1y9jhh9pchrr48zgfib2jip97x1fkm7qb1gnfx477rmmryjs500h";
+ version = "2.1.0";
+ sha256 = "0wc8v48bb0bkvypc0j6imvnf8xc8572hykk9sgjhzf2w0ggqxv5d";
};
}.${versions.majorMinor nixpkgsVersion};
diff --git a/krebs/5pkgs/haskell/much.nix b/krebs/5pkgs/haskell/much.nix
new file mode 100644
index 00000000..db168f8a
--- /dev/null
+++ b/krebs/5pkgs/haskell/much.nix
@@ -0,0 +1,29 @@
+{ mkDerivation, aeson, attoparsec, base, base64-bytestring
+, blaze-builder, blessings, bytestring, case-insensitive
+, containers, deepseq, directory, docopt, email-header, fetchgit
+, filepath, friendly-time, hyphenation, linebreak, old-locale
+, process, random, rosezipper, safe, scanner, split, stdenv
+, terminal-size, text, time, transformers, transformers-compat
+, unix, vector
+}:
+mkDerivation {
+ pname = "much";
+ version = "1.2.0";
+ src = fetchgit {
+ url = "https://cgit.krebsco.de/much";
+ sha256 = "0gfvppi8acylz0q7xh8dkm3dj676d4sc1m1gxwp663bkn4748873";
+ rev = "8fc4fbb5bb7781626da8f63cd8df8bb0f554cfe7";
+ fetchSubmodules = true;
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson attoparsec base base64-bytestring blaze-builder blessings
+ bytestring case-insensitive containers deepseq directory docopt
+ email-header filepath friendly-time hyphenation linebreak
+ old-locale process random rosezipper safe scanner split
+ terminal-size text time transformers transformers-compat unix
+ vector
+ ];
+ license = stdenv.lib.licenses.mit;
+}
diff --git a/krebs/5pkgs/haskell/reaktor2.nix b/krebs/5pkgs/haskell/reaktor2.nix
index c0c7281a..6c0a3e63 100644
--- a/krebs/5pkgs/haskell/reaktor2.nix
+++ b/krebs/5pkgs/haskell/reaktor2.nix
@@ -6,11 +6,11 @@
}:
mkDerivation {
pname = "reaktor2";
- version = "0.1.3";
+ version = "0.1.5";
src = fetchgit {
url = "https://cgit.krebsco.de/reaktor2";
- sha256 = "15qhycfja7psnd7v5hn4qb5wrs6bjx4qhny49nkhb7agj4vzwnwi";
- rev = "6c629a0cc422872abdfc40f9621ac0c4f6a420a8";
+ sha256 = "1n20ms61pp0yncs0y0mx40nj80ivv9qqv4l2ya39rfp21anmwf1s";
+ rev = "f8c5b4cfe57cb50503b8333d5d06bd0f99fdecc6";
fetchSubmodules = true;
};
isLibrary = false;