summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/reaktor2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/reaktor2.nix')
-rw-r--r--krebs/5pkgs/haskell/reaktor2.nix24
1 files changed, 14 insertions, 10 deletions
diff --git a/krebs/5pkgs/haskell/reaktor2.nix b/krebs/5pkgs/haskell/reaktor2.nix
index 44773842..40c62880 100644
--- a/krebs/5pkgs/haskell/reaktor2.nix
+++ b/krebs/5pkgs/haskell/reaktor2.nix
@@ -1,23 +1,27 @@
-{ mkDerivation, aeson, attoparsec, base, blessings, bytestring
-, containers, fetchgit, filepath, network, network-simple
-, network-simple-tls, pcre-heavy, pcre-light, process, random
-, stdenv, text, time, transformers, unix, unordered-containers
+{ mkDerivation, aeson, async, attoparsec, base, blessings
+, bytestring, containers, data-default, fetchgit, filepath
+, hashable, lens, lens-aeson, network, network-simple
+, network-simple-tls, pcre-light, process, random, stdenv
+, string-conversions, stringsearch, text, time, transformers
+, unagi-chan, unix, unordered-containers, vector
}:
mkDerivation {
pname = "reaktor2";
- version = "0.0.0";
+ version = "0.2.1";
src = fetchgit {
url = "https://cgit.krebsco.de/reaktor2";
- sha256 = "1q2rb78mzpyd8wxfmlbfdz7zq5smsrrvb4n874ap1p8f2bmmp0am";
- rev = "ce276eee82ec0b8c4106beb4c51d6f9eb77335c4";
+ sha256 = "0wg76wlzfi893rl0lzhfs6bkpdcvwvgl6mpnz6w7r8f7znr4a9vr";
+ rev = "0e199f7a357a4c5973e5837ec67699cf224ca69c";
fetchSubmodules = true;
};
isLibrary = false;
isExecutable = true;
executableHaskellDepends = [
- aeson attoparsec base blessings bytestring containers filepath
- network network-simple network-simple-tls pcre-heavy pcre-light
- process random text time transformers unix unordered-containers
+ aeson async attoparsec base blessings bytestring containers
+ data-default filepath hashable lens lens-aeson network
+ network-simple network-simple-tls pcre-light process random
+ string-conversions stringsearch text time transformers unagi-chan
+ unix unordered-containers vector
];
license = stdenv.lib.licenses.mit;
}