summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/email-header.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/email-header.nix')
-rw-r--r--krebs/5pkgs/haskell/email-header.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/krebs/5pkgs/haskell/email-header.nix b/krebs/5pkgs/haskell/email-header.nix
index 94b33e28..e1e9d423 100644
--- a/krebs/5pkgs/haskell/email-header.nix
+++ b/krebs/5pkgs/haskell/email-header.nix
@@ -1,8 +1,10 @@
-with import <stockholm/lib>;
{ mkDerivation, attoparsec, base, base64-bytestring, bytestring
, case-insensitive, containers, exceptions, fetchgit, QuickCheck
-, stdenv, tasty, tasty-quickcheck, text, text-icu, time
-}: let
+, lib, stockholm, tasty, tasty-quickcheck, text, text-icu, time
+}:
+with stockholm.lib;
+
+let
cfg = {
"18.03" = {
@@ -40,5 +42,5 @@ in mkDerivation {
jailbreak = true;
homepage = "http://github.com/knrafto/email-header";
description = "Parsing and rendering of email and MIME headers";
- license = stdenv.lib.licenses.bsd3;
+ license = lib.licenses.bsd3;
}