summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/brockman/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/brockman/default.nix')
-rw-r--r--krebs/5pkgs/haskell/brockman/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/brockman/default.nix b/krebs/5pkgs/haskell/brockman/default.nix
new file mode 100644
index 00000000..aec89b7a
--- /dev/null
+++ b/krebs/5pkgs/haskell/brockman/default.nix
@@ -0,0 +1,26 @@
+{ mkDerivation, aeson, aeson-pretty, base, bytestring
+, case-insensitive, conduit, containers, directory, feed, filepath
+, hslogger, html-entity, http-client, irc-conduit, lens, lrucache
+, network, optparse-applicative, random, safe, stdenv, text, time
+, timerep, wreq
+, fetchFromGitHub
+}:
+mkDerivation rec {
+ pname = "brockman";
+ version = "3.2.4";
+ src = fetchFromGitHub {
+ owner = "kmein";
+ repo = "brockman";
+ rev = version;
+ sha256 = "1jh2i3rxbw8x0p5xs9ph95ixpsa6h6qm0msjb9xqnw9j8by2fkk2";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson aeson-pretty base bytestring case-insensitive conduit
+ containers directory feed filepath hslogger html-entity http-client
+ irc-conduit lens lrucache network optparse-applicative random safe
+ text time timerep wreq
+ ];
+ license = stdenv.lib.licenses.mit;
+}