summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/users.nix')
-rw-r--r--krebs/3modules/users.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/krebs/3modules/users.nix b/krebs/3modules/users.nix
index c1ad4b44..b3d6ba29 100644
--- a/krebs/3modules/users.nix
+++ b/krebs/3modules/users.nix
@@ -1,8 +1,7 @@
-{ config, ... }: let
- lib = import ../../lib;
-in {
+{ config, lib, pkgs, ... }:
+{
options.krebs.users = lib.mkOption {
- type = with lib.types; attrsOf user;
+ type = with pkgs.stockholm.lib.types; attrsOf user;
};
config = lib.mkIf config.krebs.enable {
krebs.users = {