summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/users.nix')
-rw-r--r--krebs/3modules/users.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/krebs/3modules/users.nix b/krebs/3modules/users.nix
index b3d6ba29..b0ecbb85 100644
--- a/krebs/3modules/users.nix
+++ b/krebs/3modules/users.nix
@@ -1,7 +1,8 @@
-{ config, lib, pkgs, ... }:
-{
+{ config, lib, pkgs, ... }: let
+ slib = import ../../lib/lib.nix { inherit lib; };
+in {
options.krebs.users = lib.mkOption {
- type = with pkgs.stockholm.lib.types; attrsOf user;
+ type = with slib.types; attrsOf user;
};
config = lib.mkIf config.krebs.enable {
krebs.users = {