summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/upstream/window-managers/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/upstream/window-managers/default.nix')
-rw-r--r--krebs/3modules/upstream/window-managers/default.nix36
1 files changed, 18 insertions, 18 deletions
diff --git a/krebs/3modules/upstream/window-managers/default.nix b/krebs/3modules/upstream/window-managers/default.nix
index cb071f5b..cdd82076 100644
--- a/krebs/3modules/upstream/window-managers/default.nix
+++ b/krebs/3modules/upstream/window-managers/default.nix
@@ -1,22 +1,22 @@
{
imports = [
- # # Replace upstream xmonad module with one that will be reloaded if changed.
- # #
- # # This module is intended to be upstreamed once fully tested.
- # # The patch to be committed can be obtained using:
- # #
- # # diff -u <nixpkgs/nixos/modules/services/x11/window-managers/xmonad.nix> \
- # # <stockholm/tv/3modules/window-managers/xmonad.nix>
- # #
- # {
- # disabledModules = [ "services/x11/window-managers/xmonad.nix" ];
- # imports = [ ./xmonad.nix ];
- # nixpkgs.overlays = [(self: super: {
- # writers = super.writers // {
- # writeHaskellBin = name: spec:
- # super.writers.writeHaskellBin name (builtins.removeAttrs spec ["ghcArgs"]);
- # };
- # })];
- # }
+ # Replace upstream xmonad module with one that will be reloaded if changed.
+ #
+ # This module is intended to be upstreamed once fully tested.
+ # The patch to be committed can be obtained using:
+ #
+ # diff -u <nixpkgs/nixos/modules/services/x11/window-managers/xmonad.nix> \
+ # <stockholm/tv/3modules/window-managers/xmonad.nix>
+ #
+ {
+ disabledModules = [ "services/x11/window-managers/xmonad.nix" ];
+ imports = [ ./xmonad.nix ];
+ nixpkgs.overlays = [(self: super: {
+ writers = super.writers // {
+ writeHaskellBin = name: spec:
+ super.writers.writeHaskellBin name (builtins.removeAttrs spec ["ghcArgs"]);
+ };
+ })];
+ }
];
}