summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/dns.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/dns.nix')
-rw-r--r--krebs/3modules/dns.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/krebs/3modules/dns.nix b/krebs/3modules/dns.nix
index 8a74d306..60e084f5 100644
--- a/krebs/3modules/dns.nix
+++ b/krebs/3modules/dns.nix
@@ -1,5 +1,5 @@
-with import <stockholm/lib>;
-{ config, ... }: {
+{ config, lib, pkgs, ... }:
+with pkgs.stockholm.lib; {
options = {
krebs.dns.providers = mkOption {
type = types.attrsOf types.str;
@@ -8,7 +8,7 @@ with import <stockholm/lib>;
type = types.nullOr types.hostname;
};
};
- config = mkIf config.krebs.enable {
+ config = lib.mkIf config.krebs.enable {
krebs.dns.providers = {
"krebsco.de" = "zones";
shack = "hosts";