summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/charybdis.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/charybdis.nix')
-rw-r--r--krebs/3modules/charybdis.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/krebs/3modules/charybdis.nix b/krebs/3modules/charybdis.nix
index f4a7c131..aa7c980c 100644
--- a/krebs/3modules/charybdis.nix
+++ b/krebs/3modules/charybdis.nix
@@ -21,14 +21,14 @@ in
enable = mkEnableOption "Charybdis IRC daemon";
config = mkOption {
- type = types.string;
+ type = types.str;
description = ''
Charybdis IRC daemon configuration file.
'';
};
statedir = mkOption {
- type = types.string;
+ type = types.str;
default = "/var/lib/charybdis";
description = ''
Location of the state directory of charybdis.
@@ -36,7 +36,7 @@ in
};
user = mkOption {
- type = types.string;
+ type = types.str;
default = "ircd";
description = ''
Charybdis IRC daemon user.
@@ -44,7 +44,7 @@ in
};
group = mkOption {
- type = types.string;
+ type = types.str;
default = "ircd";
description = ''
Charybdis IRC daemon group.