summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/charybdis.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/charybdis.nix')
-rw-r--r--krebs/3modules/charybdis.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/krebs/3modules/charybdis.nix b/krebs/3modules/charybdis.nix
index f4a7c131..038d79dd 100644
--- a/krebs/3modules/charybdis.nix
+++ b/krebs/3modules/charybdis.nix
@@ -21,14 +21,14 @@ in
enable = mkEnableOption "Charybdis IRC daemon";
config = mkOption {
- type = types.string;
+ type = types.str;
description = ''
Charybdis IRC daemon configuration file.
'';
};
statedir = mkOption {
- type = types.string;
+ type = types.str;
default = "/var/lib/charybdis";
description = ''
Location of the state directory of charybdis.
@@ -36,7 +36,7 @@ in
};
user = mkOption {
- type = types.string;
+ type = types.str;
default = "ircd";
description = ''
Charybdis IRC daemon user.
@@ -44,7 +44,7 @@ in
};
group = mkOption {
- type = types.string;
+ type = types.str;
default = "ircd";
description = ''
Charybdis IRC daemon group.
@@ -71,14 +71,13 @@ in
config = mkIf cfg.enable (lib.mkMerge [
{
- users.users = singleton {
- name = cfg.user;
+ users.users.${cfg.user} = {
description = "Charybdis IRC daemon user";
uid = config.ids.uids.ircd;
group = cfg.group;
};
- users.groups = singleton {
+ users.groups.${cfg.group} = {
name = cfg.group;
gid = config.ids.gids.ircd;
};
@@ -102,7 +101,7 @@ in
};
}
-
+
(mkIf (cfg.motd != null) {
environment.etc."charybdis/ircd.motd".text = cfg.motd;
})