summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/bepasty-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/bepasty-server.nix')
-rw-r--r--krebs/3modules/bepasty-server.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/krebs/3modules/bepasty-server.nix b/krebs/3modules/bepasty-server.nix
index e12367b7..ffa9a29e 100644
--- a/krebs/3modules/bepasty-server.nix
+++ b/krebs/3modules/bepasty-server.nix
@@ -2,10 +2,10 @@
with import <stockholm/lib>;
let
- gunicorn = pkgs.pythonPackages.gunicorn;
+ gunicorn = pkgs.python3Packages.gunicorn;
bepasty = pkgs.bepasty;
- gevent = pkgs.pythonPackages.gevent;
- python = pkgs.pythonPackages.python;
+ gevent = pkgs.python3Packages.gevent;
+ python = pkgs.python3Packages.python;
cfg = config.krebs.bepasty;
out = {
@@ -164,7 +164,7 @@ let
client_max_body_size 32M;
'';
locations = {
- "/".extraConfig = "proxy_set_header Host $http_host;";
+ "/".extraConfig = "proxy_set_header Host $host;";
"/".proxyPass = "http://unix:${server.workDir}/gunicorn-${name}.sock";
"/static/".extraConfig = ''
alias ${bepasty}/lib/${python.libPrefix}/site-packages/bepasty/static/;