summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/node-light.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/node-light.nix')
-rw-r--r--krebs/2configs/shack/node-light.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/krebs/2configs/shack/node-light.nix b/krebs/2configs/shack/node-light.nix
index 63772f18..4a981ea8 100644
--- a/krebs/2configs/shack/node-light.nix
+++ b/krebs/2configs/shack/node-light.nix
@@ -4,9 +4,9 @@ let
pkg = pkgs.callPackage (
pkgs.fetchgit {
url = "https://git.shackspace.de/rz/node-light.git";
- rev = "a32c782650c4cc0adf51250fe249167d7246c59b";
- sha256 = "0clvcp1m2ay0a9ibh7s21q7d9a6nam3497bysvc6mdygblks22qy";
- }) {};
+ rev = "90a9347b73af3a9960bd992e6293b357226ef6a0";
+ sha256 = "1av9w3w8aknlra25jw6gqxzbb01i9kdlfziy29lwz7mnryjayvwk";
+ }) { };
home = "/var/lib/node-light";
port = "8082";
in {
@@ -28,6 +28,9 @@ in {
};
services.nginx.virtualHosts."openhab.shack" = {
+ extraConfig = ''
+ access_log syslog:server=unix:/dev/log combined if=$loggable;
+ '';
serverAliases = [ "lightapi.shack" ];
locations."/power/".proxyPass = "http://localhost:${port}/power/";
locations."/lounge/".proxyPass = "http://localhost:${port}/lounge/";
@@ -46,8 +49,9 @@ in {
'';
WorkingDirectory = home;
ExecStart = "${pkg}/bin/node-light";
- Restart = "always";
PrivateTmp = true;
+ Restart = "always";
+ RestartSec = "15";
};
};
}