summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/influx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/influx.nix')
-rw-r--r--krebs/2configs/shack/influx.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/krebs/2configs/shack/influx.nix b/krebs/2configs/shack/influx.nix
index 92cb24bf..93d83a59 100644
--- a/krebs/2configs/shack/influx.nix
+++ b/krebs/2configs/shack/influx.nix
@@ -8,6 +8,11 @@ in
networking.firewall.allowedTCPPorts = [ port ]; # for legacy applications
networking.firewall.allowedUDPPorts = [ collectd-port ];
services.nginx.virtualHosts."influx.shack" = {
+ # Disable constant GET request logging.
+ # $loggable map is defined in 1/wolf
+ extraConfig = ''
+ access_log syslog:server=unix:/dev/log combined if=$loggable;
+ '';
locations."/" = {
proxyPass = "http://localhost:${toString port}/";
};