summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/reaktor-krebs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/reaktor-krebs.nix')
-rw-r--r--krebs/2configs/reaktor-krebs.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/krebs/2configs/reaktor-krebs.nix b/krebs/2configs/reaktor-krebs.nix
new file mode 100644
index 00000000..6b17b457
--- /dev/null
+++ b/krebs/2configs/reaktor-krebs.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+with import <stockholm/lib>;
+
+{
+ krebs.Reaktor.krebs = {
+ nickname = "Reaktor|krebs";
+ channels = [
+ "#krebs"
+ "#nixos-wiki"
+ ];
+ extraEnviron = {
+ REAKTOR_HOST = "irc.freenode.org";
+ };
+ plugins = with pkgs.ReaktorPlugins; [
+ sed-plugin
+ wiki-todo-add
+ wiki-todo-done
+ wiki-todo-show
+ ];
+ };
+ services.nginx.virtualHosts."lassul.us".locations."/wiki-todo".extraConfig = ''
+ default_type "text/plain";
+ alias /var/lib/Reaktor/state/wiki-todo;
+ '';
+}