summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/mastodon.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/mastodon.nix')
-rw-r--r--krebs/2configs/mastodon.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/krebs/2configs/mastodon.nix b/krebs/2configs/mastodon.nix
index d0c1943c..145b383e 100644
--- a/krebs/2configs/mastodon.nix
+++ b/krebs/2configs/mastodon.nix
@@ -15,7 +15,7 @@
configureNginx = true;
trustedProxy = config.krebs.hosts.prism.nets.retiolum.ip6.addr;
smtp.createLocally = false;
- smtp.fromAddress = "mastodon@social.krebsco.de";
+ smtp.fromAddress = "derp";
};
services.nginx.virtualHosts.${config.services.mastodon.localDomain} = {
@@ -36,5 +36,11 @@
(pkgs.writers.writeDashBin "tootctl" ''
sudo -u mastodon /etc/profiles/per-user/mastodon/bin/mastodon-env /etc/profiles/per-user/mastodon/bin/tootctl "$@"
'')
+ (pkgs.writers.writeDashBin "create-mastodon-user" ''
+ set -efu
+ nick=$1
+ /run/current-system/sw/bin/tootctl accounts create "$nick" --email "$nick"@krebsco.de --confirmed
+ /run/current-system/sw/bin/tootctl accounts approve "$nick"
+ '')
];
}