summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/default.nix')
-rw-r--r--krebs/2configs/default.nix18
1 files changed, 6 insertions, 12 deletions
diff --git a/krebs/2configs/default.nix b/krebs/2configs/default.nix
index fafcd72c..f56f6045 100644
--- a/krebs/2configs/default.nix
+++ b/krebs/2configs/default.nix
@@ -14,18 +14,13 @@ with import <stockholm/lib>;
];
krebs.announce-activation.enable = true;
krebs.enable = true;
- krebs.tinc.retiolum.enable = true;
+ krebs.tinc.retiolum.enable = mkDefault true;
krebs.build.user = mkDefault config.krebs.users.krebs;
networking.hostName = config.krebs.build.host.name;
nix.maxJobs = 1;
- nix.trustedBinaryCaches = [
- "https://cache.nixos.org"
- "http://cache.nixos.org"
- "http://hydra.nixos.org"
- ];
nix.useSandbox = true;
environment.systemPackages = with pkgs; [
@@ -34,6 +29,11 @@ with import <stockholm/lib>;
rxvt_unicode.terminfo
];
+ console.keyMap = "us";
+ i18n = {
+ defaultLocale = lib.mkForce "C";
+ };
+
programs.ssh.startAgent = false;
services.openssh = {
@@ -43,23 +43,17 @@ with import <stockholm/lib>;
];
};
services.cron.enable = false;
- services.nscd.enable = false;
services.ntp.enable = false;
users.mutableUsers = false;
users.extraUsers.root.openssh.authorizedKeys.keys = [
- # TODO
config.krebs.users.jeschli-brauerei.pubkey
config.krebs.users.lass.pubkey
config.krebs.users.lass-mors.pubkey
config.krebs.users.makefu.pubkey
- # TODO HARDER:
- config.krebs.users.makefu-omo.pubkey
config.krebs.users.tv.pubkey
];
-
# The NixOS release to be compatible with for stateful data such as databases.
system.stateVersion = "17.03";
-
}