summaryrefslogtreecommitdiffstats
path: root/krebs/1systems/arcadeomat/hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/1systems/arcadeomat/hw.nix')
-rw-r--r--krebs/1systems/arcadeomat/hw.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/krebs/1systems/arcadeomat/hw.nix b/krebs/1systems/arcadeomat/hw.nix
new file mode 100644
index 00000000..b24deeec
--- /dev/null
+++ b/krebs/1systems/arcadeomat/hw.nix
@@ -0,0 +1,25 @@
+
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "ahci" "ohci_pci" "ehci_pci" "pata_atiixp" "usbhid" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/0aae456e-0548-4917-a282-11d5d4e403cf";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/sda";
+ boot.loader.grub.copyKernels = true;
+
+}