summaryrefslogtreecommitdiffstats
path: root/kartei/tv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kartei/tv/default.nix')
-rw-r--r--kartei/tv/default.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/kartei/tv/default.nix b/kartei/tv/default.nix
index eacb40af..b203675f 100644
--- a/kartei/tv/default.nix
+++ b/kartei/tv/default.nix
@@ -1,5 +1,4 @@
-with import ../../lib;
-{ config, ... }: {
+{ config, lib, stockholm, ... }: with lib; {
dns.providers = {
"viljetic.de" = "regfish";
};
@@ -7,11 +6,11 @@ with import ../../lib;
mapAttrs
(hostName: hostFile: let
hostSource = import hostFile;
- hostConfig = getAttr (typeOf hostSource) {
- lambda = hostSource { inherit config lib; };
+ hostConfig = getAttr (builtins.typeOf hostSource) {
+ lambda = hostSource { inherit config; lib = stockholm.lib; };
set = hostSource;
};
- in evalSubmodule types.host [
+ in stockholm.lib.evalSubmodule stockholm.lib.types.host [
hostConfig
{
name = hostName;
@@ -20,7 +19,7 @@ with import ../../lib;
(optionalAttrs (hasAttrByPath ["nets" "retiolum"] hostConfig) {
nets.retiolum = {
ip6.addr =
- (krebs.genipv6 "retiolum" "tv" { inherit hostName; }).address;
+ (stockholm.lib.krebs.genipv6 "retiolum" "tv" { inherit hostName; }).address;
};
})
(let
@@ -31,7 +30,7 @@ with import ../../lib;
"${hostName}.w"
];
ip6.addr =
- (krebs.genipv6 "wiregrill" "tv" { inherit hostName; }).address;
+ (stockholm.lib.krebs.genipv6 "wiregrill" "tv" { inherit hostName; }).address;
wireguard.pubkey = readFile pubkey-path;
};
})
@@ -47,7 +46,7 @@ with import ../../lib;
name = removeSuffix ".nix" name;
value = ./hosts + "/${name}";
})
- (readDir ./hosts));
+ (builtins.readDir ./hosts));
sitemap = {
"http://cgit.krebsco.de" = {
desc = "Git repositories";