summaryrefslogtreecommitdiffstats
path: root/jeschli/2configs/steam.nix
diff options
context:
space:
mode:
Diffstat (limited to 'jeschli/2configs/steam.nix')
-rw-r--r--jeschli/2configs/steam.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/jeschli/2configs/steam.nix b/jeschli/2configs/steam.nix
new file mode 100644
index 00000000..4d2d66c6
--- /dev/null
+++ b/jeschli/2configs/steam.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, ... }:
+
+{
+
+ nixpkgs.config.steam.java = true;
+ environment.systemPackages = with pkgs; [
+ steam
+ ];
+ hardware.opengl.driSupport32Bit = true;
+
+ #ports for inhome streaming
+ krebs.iptables = {
+ tables = {
+ filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 27031"; target = "ACCEPT"; }
+ { predicate = "-p tcp --dport 27036"; target = "ACCEPT"; }
+ { predicate = "-p udp --dport 27031"; target = "ACCEPT"; }
+ { predicate = "-p udp --dport 27036"; target = "ACCEPT"; }
+ ];
+ };
+ };
+}