summaryrefslogtreecommitdiffstats
path: root/jeschli/2configs/emacs-org-agenda.nix
diff options
context:
space:
mode:
Diffstat (limited to 'jeschli/2configs/emacs-org-agenda.nix')
-rw-r--r--jeschli/2configs/emacs-org-agenda.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/jeschli/2configs/emacs-org-agenda.nix b/jeschli/2configs/emacs-org-agenda.nix
index f9139fcf..0420dc43 100644
--- a/jeschli/2configs/emacs-org-agenda.nix
+++ b/jeschli/2configs/emacs-org-agenda.nix
@@ -114,29 +114,29 @@ let
("NEXT" ("WAITING") ("CANCELLED") ("HOLD"))
("DONE" ("WAITING") ("CANCELLED") ("HOLD")))))
-(setq org-directory "~/projects/notes_private")
-(setq org-default-notes-file "~/projects/notes_private/refile.org")
+(setq org-directory "~/projects/notes_privat")
+(setq org-default-notes-file "~/projects/notes_privat/refile.org")
;; I use C-c c to start capture mode
(global-set-key (kbd "C-c c") 'org-capture)
;; Capture templates for: TODO tasks, Notes, appointments, phone calls, meetings, and org-protocol
(setq org-capture-templates
- (quote (("t" "todo" entry (file "~/git/org/refile.org")
+ (quote (("t" "todo" entry (file org-default-notes-file)
"* TODO %?\n%U\n%a\n" :clock-in t :clock-resume t)
- ("r" "respond" entry (file "~/git/org/refile.org")
+ ("r" "respond" entry (file org-default-notes-file)
"* NEXT Respond to %:from on %:subject\nSCHEDULED: %t\n%U\n%a\n" :clock-in t :clock-resume t :immediate-finish t)
- ("n" "note" entry (file "~/git/org/refile.org")
+ ("n" "note" entry (file org-default-notes-file)
"* %? :NOTE:\n%U\n%a\n" :clock-in t :clock-resume t)
("j" "Journal" entry (file+datetree "~/git/org/diary.org")
"* %?\n%U\n" :clock-in t :clock-resume t)
- ("w" "org-protocol" entry (file "~/git/org/refile.org")
+ ("w" "org-protocol" entry (file org-default-notes-file)
"* TODO Review %c\n%U\n" :immediate-finish t)
- ("m" "Meeting" entry (file "~/git/org/refile.org")
+ ("m" "Meeting" entry (file org-default-notes-file)
"* MEETING with %? :MEETING:\n%U" :clock-in t :clock-resume t)
- ("p" "Phone call" entry (file "~/git/org/refile.org")
+ ("p" "Phone call" entry (file org-default-notes-file)
"* PHONE %? :PHONE:\n%U" :clock-in t :clock-resume t)
- ("h" "Habit" entry (file "~/git/org/refile.org")
+ ("h" "Habit" entry (file org-default-notes-file)
"* NEXT %?\n%U\n%a\nSCHEDULED: %(format-time-string \"%<<%Y-%m-%d %a .+1d/3d>>\")\n:PROPERTIES:\n:STYLE: habit\n:REPEAT_TO_STATE: NEXT\n:END:\n"))))
;; Remove empty LOGBOOK drawers on clock out
@@ -144,7 +144,7 @@ let
(interactive)
(save-excursion
(beginning-of-line 0)
- (org-remove-empty-drawer-at "LOGBOOK" (point))))
+ (org-remove-empty-drawer-at (point))))
(add-hook 'org-clock-out-hook 'bh/remove-empty-drawer-on-clock-out 'append)